Prosecution Insights
Last updated: October 02, 2026
Application No. 19/193,133

Communication Method, Communication Apparatus, and Computer-Readable Storage Medium

Non-Final OA §102
Filed
Apr 29, 2025
Priority
Oct 31, 2022 — CN 202211347850.X +1 more
Examiner
ZHANG, SHIRLEY X
Art Unit
Tech Center
Assignee
Huawei Technologies Co., Ltd.
OA Round
1 (Non-Final)
70%
Grant Probability
Favorable
1-2
OA Rounds
1y 11m
Est. Remaining
84%
With Interview

Examiner Intelligence

Grants 70% — above average
70%
Career Allowance Rate
433 granted / 620 resolved
+9.8% vs TC avg
Moderate +14% lift
Without
With
+14.2%
Interview Lift
resolved cases with interview
Typical timeline
3y 4m
Avg Prosecution
14 currently pending
Career history
639
Total Applications
across all art units

Statute-Specific Performance

§101
14.5%
-25.5% vs TC avg
§103
43.8%
+3.8% vs TC avg
§102
20.2%
-19.8% vs TC avg
§112
12.9%
-27.1% vs TC avg
Black line = Tech Center average estimate • Based on career data from 620 resolved cases

Office Action

§102
Notice of Pre-AIA or AIA Status The present application, filed on or after March 16, 2013, is being examined under the first inventor to file provisions of the AIA . DETAILED ACTION This non-final office action is responsive to the U.S. patent application no. 19/193,133 filed on April 29, 2025. Claims 1-20 are pending. Claims 1, 4-5, 7-8, 11-12, 14-16 and 19-20 are rejected. Claims 2-3, 6, 9-10, 13 and 17-18 are objected to. Priority The application claims foreign priority under 35 U.S.C. 119(a)-(d) to foreign application No. CN202211347850.X filed on October 31, 2022. The application claims priority under 35 U.S.C. 365(a) to the international application PCT/CN2023/125931 filed on October 23, 2023. A certified copy of the foreign application submitted under 35 U.S.C. 119(a)-(d) was received on June 4, 2025, and has been placed in the file of record. Information Disclosure Statement The information disclosure statement (IDS) submitted on May 22nd, 2025, is compliant with the provisions of 37 CFR 1.97. Accordingly, the information disclosure statement has been considered by the examiner. Allowable Subject Matter Claims 2-3, 6, 9-10, 13, 17-18 are objected to as being dependent upon rejected base claims but would be allowable if rewritten in independent form including all the limitations of the base claim and any intervening claims. Claim Rejections - 35 USC § 102 The following is a quotation of the appropriate paragraphs of 35 U.S.C. 102 that form the basis for the rejections under this section made in this Office action: A person shall be entitled to a patent unless – (a)(2) the claimed invention was described in a patent issued under section 151, or in an application for patent published or deemed published under section 122(b), in which the patent or application, as the case may be, names another inventor and was effectively filed before the effective filing date of the claimed invention. Claims 1, 4-5, 7-8, 11-12, 14-16, and 19-20 are rejected under 35 U.S.C. 102(a)(2) as being unpatentable over RFC8210: The Resource Public Key Infrastructure (RPKI) to Router Protocol, version 1, hereinafter referred to as “RFC8210”. Regarding claim 1, RFC8210 disclosed a communication method implemented by a network device, wherein the communication method comprises: sending a data request message to a resource public key infrastructure (RPKI) server to request the RPKI server to send first data corresponding to a first data type of multiple data types (RFC8210 disclosed on page 21, section 8.1 the typical sequence of PDU transmission for a “start or restart” conversation between a router and a RPKI cache, where the router sends a “Reset Query” or “Serial Query” to the cache. Said “Reset Query” or “Serial Query” anticipates the data request message in the claim), wherein the data request message comprises an identifier of the first data type (RFC8210 disclosed on page 12, section 5.4 that the Reset Query contains a PDU type field. This PDU type field anticipates the “first data type” in the claim. See RFC8210, section 5.1 for more information on the PDU Type field); and receiving the first data from the RPKI server in response to the data request message (RFC8210 disclosed on page 21, section 8.1 that the Router receives Cache Response and Payload PDU from the RPKI Cache server in response to its Query). Claim 8 lists substantially the same elements as claim 1 in method form, but from the perspective of an RPKI server instead of a router. Therefore, the rejection rationale for claim 1 applies equally as well to claim 8. Claim 16 lists substantially the same elements as claim 1 in apparatus form rather than method form. Therefore, the rejection rationale for claim 1 applies equally as well to claim 16. Regarding claims 4, 11 and 19, RFC8210 disclosed the subject matter of claims 1, 8 and 16 respectively. RFC8210 further disclosed wherein the data request message is a specific data reset query message, and wherein the specific data reset query message, further requests the RPKI server to send all data corresponding to the first data type, and wherein all the data includes the first data (RFC8210, pages 21-23, section 8.1-8.3, “Reset Query”). Regarding claims 5, 12 and 20, RFC8210 disclosed the subject matter of claims 1, 8 and 16 respectively. RFC8210 further disclosed wherein the data request message is a specific data serial number query message, and wherein the specific data serial number query message, requests the RPKI server to send updated data corresponding to the first data type (RFC8210, pages 21-23, section 8.1-8.3, “Serial Query”). Regarding claims 7 and 15, RFC8210 disclosed the subject matter of claims 1 and 8 respectively. RFC8210 further disclosed wherein the multiple data types comprise at least two of an Internet Protocol version 4 (IPv4) prefix, an Internet Protocol version 6 (IPv6) prefix, autonomous system provider authorization, or a router public key (RFC8210, pages 7-8, section 5.1, “PDU Type”, e.g. IPv4 Prefix or IPv6 Prefix; page 9, “Subject Public Key Info”). Regarding claim 14, RFC8210 disclosed the method of claim 8. RFC8210 further disclosed sending a specific data notification message to the network device for notifying the network device that the first data is updated, that the RPKI server acknowledges the data request message, or that the RPKI server is unable to respond to the data request message, wherein the specific data notification message comprises the first identifier (RFC8210, page 10 section 5.2 and page 22, section 8.2, “Serial Notify”). Related Prior Art RFC6480: An Infrastructure to Support Secure Internet Routing, 2012 RFC8181: A Publication Protocol for the Resource Public Key Infrastructure (RPKI), 2017 Conclusion Any inquiry concerning this communication or earlier communications from the examiner should be directed to SHIRLEY X ZHANG whose telephone number is (571)270-5012. The examiner can normally be reached 8:30am - 5:00pm. Examiner interviews are available via telephone, in-person, and video conferencing using a USPTO supplied web-based collaboration tool. To schedule an interview, applicant is encouraged to use the USPTO Automated Interview Request (AIR) at http://www.uspto.gov/interviewpractice. If attempts to reach the examiner by telephone are unsuccessful, the examiner’s supervisor, Joon H Hwang can be reached at 571-272-4036. The fax phone number for the organization where this application or proceeding is assigned is 571-273-8300. Information regarding the status of published or unpublished applications may be obtained from Patent Center. Unpublished application information in Patent Center is available to registered users. To file and manage patent submissions in Patent Center, visit: https://patentcenter.uspto.gov. Visit https://www.uspto.gov/patents/apply/patent-center for more information about Patent Center and https://www.uspto.gov/patents/docx for information about filing in DOCX format. For additional questions, contact the Electronic Business Center (EBC) at 866-217-9197 (toll-free). If you would like assistance from a USPTO Customer Service Representative, call 800-786-9199 (IN USA OR CANADA) or 571-272-1000. /SHIRLEY X ZHANG/Primary Examiner, Art Unit 2447
Read full office action

Prosecution Timeline

Apr 29, 2025
Application Filed
Sep 08, 2026
Non-Final Rejection mailed — §102 (current)

Precedent Cases

Applications granted by this same examiner with similar technology

Patent 12750283
INTERPRETING AND CATEGORIZING TRAFFIC ON INDUSTRIAL CONTROL NETWORKS
1y 7m to grant Granted Sep 29, 2026
Patent 12731032
Adaptable On-Deployment Learning Platform for Driver Analysis Output Generation
1y 8m to grant Granted Sep 08, 2026
Patent 12705365
METHOD AND PROGRAM PRODUCT FOR IDENTIFYING BEHAVIORAL ANOMALIES AND RISK FACTORS IN SOFTWARE DEVELOPMENT
1y 10m to grant Granted Aug 11, 2026
Patent 12701278
SYSTEM AND METHOD FOR ENCODING IMAGE DATA AND OTHER DATA TYPES INTO ONE DATA FORMAT AND DECODING OF SAME
2y 9m to grant Granted Aug 04, 2026
Patent 12683869
MACHINE LEARNING LANGUAGE BASED DYNAMIC NETWORK DISCOVERY
3y 3m to grant Granted Jul 14, 2026
Study what changed to get past this examiner. Based on 5 most recent grants.

Strategy Recommendation AI-generated — please review before filing

Get a prosecution strategy drawn from examiner precedents, rejection analysis, and claim mapping.
Typically takes 5-10 seconds — AI-generated, attorney review required before filing

Prosecution Projections

1-2
Expected OA Rounds
70%
Grant Probability
84%
With Interview (+14.2%)
3y 4m (~1y 11m remaining)
Median Time to Grant
Low
PTA Risk
Based on 620 resolved cases by this examiner. Grant probability derived from career allowance rate.

Sign in with your work email

Enter your email to receive a magic link. No password needed.

Personal email addresses (Gmail, Yahoo, etc.) are not accepted.

Free tier: 3 strategy analyses per month